I have began learning OpenBSD and before my bookmarks get filled further I am documenting the essential FAQ, man pages, etc I come across deemed essential for understanding and learning the system. As I am a beginner of the system myself, this is not completely comprehensive or may not be accurate as what is deemed essential to one may not be to another as it is subjective.
In essence, read the manuals it is very comprehensive.
Manuals and FAQs
Here is a list of some useful manual pages for new users:
-
afterboot(8) - things to check after the first complete boot.
-
help(1) - help for new users and administrators.
-
hier(7) - layout of filesystems.
-
man(1) - display the manual pages.
-
adduser(8) and rmuser(8) - add or remove new users.
-
reboot(8), halt(8) and shutdown(8) - stop and restart the system.
-
dmesg(8) - redisplay the kernel boot messages.
-
doas(1) - run commands as another user.
-
tmux(1) - terminal multiplexer.
-
ifconfig(8) - configure network interface parameters.
-
login.conf(5) - format of the login class configuration file.
-
sendbug(1) - report a bug you’ve found.
Understanding OpenBSD
Confusing things for Linux users
-
lsblk equivalent is disklabel -h
-
After a disk has an MBR partition (using fdisk as an example), use disklabel to create labels to divide up the partition (Similar to LVM kind of)
-
After labels are created, use newfs to create a filesystem on each of the new labels
-
The dmesg log is stored under /var/run/ and is called dmesg.boot, it is not under /var/log/
-
sudo was replaced by doas
-
DUID (disklabel unique identifier) is similar in concept to a UUID (Universally Unique Identifier). One big difference being that DUIDs refer to whole disks or MBR partitions, rather than a UUID per file system. To refer to an individual disklabel explicitly such as for in fstab, use
. -
In place of mdadm, reference bioctl and softraid manual pages instead. Additionally, softraid builds its virtual disks out of disklabel partitions